photoshop embuggered

Post Reply
User avatar
Posts: 1373
Joined: Sat Apr 09, 2005 8:24 am

photoshop embuggered

Post by Gaz » Tue Jan 30, 2007 8:38 pm

when you try to open it says this:

"could not initialize Photoshop because the file is locked. Use the 'Properties' command in the Windows Explorer to unlock the file"

this happens when you try to open a file or just the program.
something simple no doubt...what do you do to fix it?
the more you think, the more you stink

User avatar
Posts: 1373
Joined: Sat Apr 09, 2005 8:24 am

Post by Gaz » Thu Feb 01, 2007 9:43 pm

Maybe someone can fix it using this:
On MS Windows XP Professional (SP1) when a limited user tries to start Adobe Photoshop CS v.8.0 he gets the following error message:
"Could not initialize Photoshop because the file is locked.
Use the 'Properties' command in the Windows Explorer to unlock the file."

It seems that the cause of the problem is the location for Photoshop
scratch file (a kind of temporary file. In Photoshop CS you can set the
volumes (i.e. partitions) for scratch files in the following way:
Edit -> Preferences -> Plug-Ins & Scratch Disks
You can define up to four scratch volumes.

Here is how the problem happened in my case:
The Photoshop CS v.8.0 was installed by an administrator on the system
partition, i.e. on the partition where the Windows folder is located
(also the "Documents and Settings" and "Program Files" folders) -- by
default this is the C: partition.
When the Photoshop was first started by a limited user account (who
was not member of the local administrators group) he got the following
"You currently have Adobe Photoshop's primary Scratch and Windows'
primary paging file on the same volume, which can result in reduced
performance. It is recommended that you set Adobe Photoshop's primary
Scratch volume to be on a different volume, preferably on a different
physical drive."

Following that recommendation the user set the Photoshop first scratch
volume to D:\ (this was the second hard disk on his PC). But after
closing Photoshop he was unable to start it again because of the
error, "Could not initialize Photoshop because the file is locked ..."

The problem is that the Photoshop is unable to create the scratch file
on the D: partition as in Windows XP limited users don't have right by
default to create files on the root of a partition (D:\).

On the other hand if the first scratch volume is set to "Startup",
then Photoshop opens the scratch file on the partition where it was
installed, which is here the system partition. More precisely, in that
case Photoshop opens the scratch file in the temporary folder pointed
by the TEMP and TMP Windows environment variables. By default, these
variables have the value, "%USERPROFILE%\Local Settings\Temp" where
%USERPROFILE% is another Windows environment variable that points to
the user profile folder, e.g. "C:\Documents and %Settings\user_name".

Conclusion: if you want to have the Photoshop scratch file on a
partition which is not the system partition, you also have to have
right to write files to the root of that partition.

If you are not allowed to have that right, then as a workaround you
can restore the Photoshop default user preferences by renaming or
deleting the "Adobe Photoshop CS Prefs.psp" file in your user profile
folder -- more precisely in the folder,
%USERPROFILE%\Application Data\Adobe\Photoshop\8.0\Adobe Photoshop CS Settings\
(you can copy the path and open it in the Windows Explorer).

In my opinion this is a bug in Photoshop. When user changes the
scratch drives, Photoshop should check if it is able to open a file on
the corresponding location before allowing the change. Also, if it is
unable to open the scratch file afterwards, it should try to open the
file at another location.
According to some previous articles in the news groups, this bug also
existed in some previous versions of Photoshop and it is strange that
it hasn't been corrected yet.

-- rpr. /Robert Premuz/
the more you think, the more you stink

User avatar
Posts: 405
Joined: Sun Apr 10, 2005 8:22 pm

Post by Duncan » Fri Feb 02, 2007 5:38 pm

Bugger, I was having a go (unfruitfully) yesterday, wish I'd spotted this before.

Will have another go tonight.

In the meantime I installed Photoshop 7.0 so you can do stuff. Meant to mention earlier today of course.

Tried to install Photoshop 9.0 (CS2) on the new machine, but the serial wouldn't work. Got hold of another one online and still no joy. Any clues ?
I love the bomb.

Post Reply